1. vinay

    vinay Well-Known Member

    Sep 3, 2011
    281
    Re: #1130 - Host 'localhost' is not allowed to connect to this MySQL server

    How can solve this :facepalm:
     
  2. Tango

    Tango Super Moderator Staff Member

    Jul 9, 2009
    3,223
    Check in phpmyadmin 'Privileges' for root user

    It should show localhost access

    [​IMG]


    The fix would depend on what panel your using if any.
     
  3. vinay

    vinay Well-Known Member

    Sep 3, 2011
    281
    i am using xampp/home xp and after click phpmyadmin then show error

    [​IMG]
     
    Last edited: Apr 11, 2012
  4. cyber-cliff

    cyber-cliff Banned Banned

    Jul 15, 2008
    1,181
  5. vinay

    vinay Well-Known Member

    Sep 3, 2011
    281
    problem not solved facing same error
     
  6. Phogo

    Phogo Well-Known Member

    Dec 6, 2009
    107
    Post your config file
     
  7. Digilife

    Digilife Active Member

    Oct 6, 2011
    25
    Post your phpmyadmin config. So we can look at it.
     
  8. vinay

    vinay Well-Known Member

    Sep 3, 2011
    281
    this problem solved but show me error during install [​IMG]
     
  9. mintcold

    mintcold Well-Known Member

    Oct 2, 2011
    262
    From the little info that you have given here are my suggestions --

    #I am guessing that you are trying this on your local machine , if so , the username should be 'root' and no password is required

    #If you are trying this on a live server , in that case you need to provide a password to connect to the DB ... (ofc the user 'gfxhotra' needs to be added with proper privileges to the DB you are trying to connect with)
     
  10. Lock Down

    Lock Down Well-Known Member

    Feb 21, 2010
    2,122
    Did you create a datebase and user?? Then give the user access to database?

    Does the user have a password ??
     
  11. vinay

    vinay Well-Known Member

    Sep 3, 2011
    281
    edit
     
    Last edited: Apr 29, 2012
  12. vinay

    vinay Well-Known Member

    Sep 3, 2011
    281
    anyone tell me how can solve this?
     
  13. NewEraCracker

    NewEraCracker Well-Known Member

    May 22, 2010
    1,335
    I know this is an old thread anyway it could be related to a PHP 5.3 mysqlnd/php sockets bug present in earlier php versions related with IPv6 issues. You will likely face this issues if using php less than 5.3.5 with NT 6.0 OS (Windows Vista, 7, 2008).

    You could edit phpmyadmin configuration file (config.inc.php) and replace all the instances of localhost with 127.0.0.1
    Code:
    $cfg['Servers'][$i]['host'] = '127.0.0.1'
    It could be also caused by Windows/MySQL misconfiguration regarding host resolution, if so, start cmd.exe as administrator and run:
    Code:
    notepad %windir%\system32\drivers\etc\hosts
    To edit your hosts file and add the following line if not present already
    Code:
    127.0.0.1 localhost
    Regards,
    NewEraCracker
     

Share This Page