1. Skyhel

    Skyhel Member

    Jul 1, 2018
    9
  2. Hyperz

    Hyperz Well-Known Member Respected

    Feb 8, 2009
    2,251
    Sounds like you installed the 32-bits version. You need a 64-bit OS for >2 GB of RAM.
     
  3. Skyhel

    Skyhel Member

    Jul 1, 2018
    9
    No i really installed the x64-bit!
     
  4. Skyhel

    Skyhel Member

    Jul 1, 2018
    9
    Maybe I need to change this
    mount -t tmpfs -o size=8000m tmpfs /mnt ? Caus i release know nothing about ssh commande I never did that
     
  5. RapidVideo

    RapidVideo Well-Known Member Affiliate Rep.

    Feb 12, 2012
    1,685
    every 32bit OS have only 4 GB allocate RAM maxinum, but it does not mean that you can use all 4 GB for OS alone. For example, IRQ, drivers, chipset, etc, graphic memory also use the RAM address space, and because if the Graphic memory is 2 GB, it will also take the 2 GB adress space in the RAM allocation and push the 4 GB RAM behind further.

    As Hyperz said, you need 64bit OS to allocate everything in the virtual RAM adress space.
     
  6. Skyhel

    Skyhel Member

    Jul 1, 2018
    9
    how to allocate everything in the virtual RAM adress space ? please
     
  7. RapidVideo

    RapidVideo Well-Known Member Affiliate Rep.

    Feb 12, 2012
    1,685
    As I explained before, the 32bit OS can only handle 4 GB virtual memory... If your OS is running native and not in qemu with 2GB RAM, then this is wrong.

    Edit: As i read the tutorial, the qemu is started with 2 GB virtual memory.
     
  8. Skyhel

    Skyhel Member

    Jul 1, 2018
    9
    i really dont understand anything ... i dont know what is native or not i juste followed the tutorial by copy/past :(
     
  9. RapidVideo

    RapidVideo Well-Known Member Affiliate Rep.

    Feb 12, 2012
    1,685
    If you start the qemu as in the Tutorial explained, it only give you 2 GB virtual RAM. This is not an error.
     
  10. Skyhel

    Skyhel Member

    Jul 1, 2018
    9
    Please how can i start it to give me 32GB RAM ?
    Caus i really dont know what im ddoing im noob
     
    Last edited: Jul 4, 2018
  11. Hyperz

    Hyperz Well-Known Member Respected

    Feb 8, 2009
    2,251
    I probably should have looked at the commands before replying. I'm not too familiar with this stuff. Anyway, as RapidVideo hinted it's a command line argument. In this command:

    Code:
    /tmp/qemu-system-x86_64 -net nic -net user,hostfwd=tcp::3389-:3389 -m 2048M -localtime -enable-kvm -cpu host,+nx -M pc -smp 2 -vga std -usbdevice tablet -k en-us -hda /dev/sda -boot c -vnc :1
    Change -m 2048M to whatever you need. 8192M would give you 8GB etc. https://linux.die.net/man/1/qemu-kvm
     
  12. Skyhel

    Skyhel Member

    Jul 1, 2018
    9
    Thanks :)
     

Share This Page