script works on localhost but not on real server

UnknownGuy

Well-Known Member
119
40
28
2018
375
I installed Easycomment comment PHP script on my localhost and everything worked out fine, I could login.

But when installing on a real web server it installs but can't login. Login button don't do anything when clicked,

Database Port: 3306 (default)
Database host: localhost (default)

Here's the script link (unzipped):

I would appreciate any kind of help!
 
13 comments

Mucha

Well-Known Member
418
217
43
2019
901
Provide logs from server, usually apps that allows to create localhost server with php environment have pre installed all common packages which your server might not have installed.
 

UnknownGuy

Well-Known Member
119
40
28
2018
375
Provide logs from server, usually apps that allows to create localhost server with php environment have pre installed all common packages which your server might not have installed.
how do i get logs, i have shared hosting
 

Mucha

Well-Known Member
418
217
43
2019
901
Go to Metrics > Error Logs it will display to you around 300 of last error logs, if nothing is there enable php debug for that you will need to visit Software > Select PHP Version > Switch to PHP Options there you will be able to find error_reporting and then enable it like this:

Code:
E_ALL : Everything
E_ALL & ~E_NOTICE : Report all errors except E_NOTICE
~E_ALL : Disable all
Also you can link me your website with some test account to test login maybe there is something displayed in dev console.
 

UnknownGuy

Well-Known Member
119
40
28
2018
375
Go to Metrics > Error Logs it will display to you around 300 of last error logs, if nothing is there enable php debug for that you will need to visit Software > Select PHP Version > Switch to PHP Options there you will be able to find error_reporting and then enable it like this:

Code:
E_ALL : Everything
E_ALL & ~E_NOTICE : Report all errors except E_NOTICE
~E_ALL : Disable all
Also you can link me your website with some test account to test login maybe there is something displayed in dev console.
no error found on metrics error
I'm now in the software> SELECT PHP
what to do now?
 
Last edited:

Mucha

Well-Known Member
418
217
43
2019
901
Go to options tab find error_reporting and turn it on, set it to E-ALL also display errors set to ON
 

Mucha

Well-Known Member
418
217
43
2019
901
Your host is bad then, write support ticket to them as i see first time in my life that shared webhost offer less than basic. Also before you make ticket provide me with your website url so i can check if there is anything in dev console being displayed.

@Tango cleared it out, you dont comply with script requirements.
 

UnknownGuy

Well-Known Member
119
40
28
2018
375
Your host is bad then, write support ticket to them as i see first time in my life that shared webhost offer less than basic. Also before you make ticket provide me with your website url so i can check if there is anything in dev console being displayed.

@Tango cleared it out, you dont comply with script requirements.
check you PM
 
Top Bottom