1. K3V

    K3V Well-Known Member Respected

    Jul 13, 2009
    881
    How can i access localhost (My Server) through my IP instead of gettin' my router config page ?

    I googled & figured i needed to re-direct my ports, I set that up but still no luck =/

    [​IMG]

    Anyone know anything ?

    I have a D-Link DSL-2640R if that helps. Thanks :)
     
  2. Sponge Bob

    Sponge Bob Well-Known Member Respected

    Aug 16, 2009
    3,153
    Hey i think your Router gateway ip is 191.168.1.1

    Well just do this, change that gateway ip to 192.168.2.1 or something then release and renew your ip to get a new ip on the new gateway then on the browser try localhost.

    It will work.

    Cheerz
     
  3. l0calh0st

    l0calh0st Well-Known Member

    Mar 26, 2010
    4,052
    just type: localhost in you browser.
    if you are on an other network, you should put your ip in your browser.

    note: you have to forward your external ip to your local system ip.
     
  4. sniper

    sniper Banned Banned

    Dec 29, 2009
    521
    Check your Ip address of your PC.
    You can do this My using ipconfig

    If its 192.168.1.1 change it in Private ip.s
    also put the port range 56355 - 56357
     
  5. Sponge Bob

    Sponge Bob Well-Known Member Respected

    Aug 16, 2009
    3,153
    Oops sorry did not get your question right the first time.
    This is simple you dont even need to do any config on your router.

    What you do is get the IP of your computer, and add it to your browser and it will work.

    Let me know once it works :)
     
  6. K3V

    K3V Well-Known Member Respected

    Jul 13, 2009
    881
    I have tried 192.168.1.1 but i get "The Gateway IP is not allowed!"
     
  7. Lock Down

    Lock Down Well-Known Member

    Feb 21, 2010
    2,122
    try using the ipconfig /all command as sniper suggested and see what it tells you your ip and gateway addresses are set.

    Then report them here if you are still confused.
     
  8. l0calh0st

    l0calh0st Well-Known Member

    Mar 26, 2010
    4,052
    if you want to login into your router try:
    192.168.0.1
    192.168.1.0
    192.168.0.01

    if you want to visit your local server try: 127.0.0.1 or localhost
     
  9. sniper

    sniper Banned Banned

    Dec 29, 2009
    521
    He wants to access Localhost...Lols give access l0calh0st
     
  10. l0calh0st

    l0calh0st Well-Known Member

    Mar 26, 2010
    4,052
    @Sniper lmao!
     
  11. indahouse

    indahouse Well-Known Member

    Feb 26, 2010
    323
    You must configure aplication rules in your router to access to port 80 from internet.
     
  12. K3V

    K3V Well-Known Member Respected

    Jul 13, 2009
    881
    I can access it throught 127.0.0.1 & Localhost but thats not what i want,
    I want to share my IP so others on outside can access it.

    This is IPConfig ...
    [​IMG]
     
  13. DLow

    DLow Banned Banned

    Oct 17, 2009
    4,007
    K3V basically wants it to where other people can connect to the computer via

    ftp://IPHERE

    :)
     
  14. Sandino

    Sandino Well-Known Member

    Sep 14, 2009
    2,098
    Are you using a program for the server ? (wamp, xamp, etc).
    Or a server just for that.

    Also, there is no way to get your server's page instead of router page, unless you change your router's IP (which some router's can or cannot do), or you can try to change the server's ip.
     
  15. K3V

    K3V Well-Known Member Respected

    Jul 13, 2009
    881
    Yeah, Im using XAMPP, So how do i go about this ?
     
  16. oOo

    oOo Member

    Sep 8, 2009
    24
    Basically what you have to do is forward port 80 to your PC. Protocol type can be set to TCP only as far as I'm aware of.

    You have to make sure that the "remote management" (advanced tab, then on the left side) of your router is turned off. You might want to turn of the router firewall for a second just to see if it works without.
     
  17. Sandino

    Sandino Well-Known Member

    Sep 14, 2009
    2,098
    Well if you are on your computer, you should be putting in the computer's ip (where it's hosted) not your router's IP. (So not sure why you are getting your router's IP -- maybe putting in wrong IP?)

    If you are able to view the stuff locally (even by typing in localhost), then it's probably a port problem. If you have already enabled port 80 for your machine, then the easiest thing would probably be just changing the port in the httpd.conf file, restarting apache, then opening that port on your router.

    Then you should be able to view it by using your external IP. (not 192.168)

    Unless... xampp has a way to "put apache online" like wamp does. ( I do not recall ).
    Which what wamp does is only allow local access to apache, when you turn on apache, it then allows viewers from the "outside" world to see your website(s).
    If it does, then that's probably the problem.


    _____
    Edit.

    Actually, maybe I misread, but if you are saying people are putting your external IP and getting your router's page, then you can try to disable that in your router if it lets you. (you can just google it and see if your router allows you to).
    or the simple way, is like I said change the listen port in httpd.conf
     
  18. Lock Down

    Lock Down Well-Known Member

    Feb 21, 2010
    2,122
    You are not showing any connection outside your home. Connection-specific DNS suffix should show your outside address (internet).
     
  19. Crossy

    Crossy Well-Known Member

    Mar 8, 2009
    468
    ask splitice he is pro
     
  20. dantehaines

    dantehaines New Member

    Apr 15, 2019
    1
    Please suggest me also.
     

Share This Page