1. SHiTHEAD

    SHiTHEAD New Member Member

    Jul 12, 2010
    13
    Hi, can anyone tell me how to install Ubuntu Desktop... I have Ubuntu [FONT=PrimaSans BT,Verdana,sans-serif]10.4 64 bit... I need also gnome and vnc... Thanks in advance...[/FONT]
     
  2. DLow

    DLow Banned Banned

    Oct 17, 2009
    4,007
    google gnome and vnc :s and go into your vps container manager rather it be vds manager, solus vm, hypervm & re-iso the virtual machine to ubuntu
     
  3. shadow.prx

    shadow.prx New Member Member

    Jan 24, 2009
    2,369
    Their are thousands of guides on the net just google it
    Code:
    http://www.usefuljaja.com/vps
    <that was the 1st one on google
    TO install gnome just
    Code:
    sudo apt-get install gnome
    And here is a useful guide for vnc
    Code:
    http://lifehacker.com/317125/set-up-vnc-on-ubuntu-in-four-steps
     
  4. SHiTHEAD

    SHiTHEAD New Member Member

    Jul 12, 2010
    13
    @DLow i did that but they have only ubuntu server...
    @for that sudo apt-get i get sudo apt-get command not found...

    I also tried
    Code:
    [FONT=monospace][B]sudo apt-get install ubuntu-desktop[/B][/FONT]
    but i also get that error message sudo apt-get command not found...


     
  5. hamza

    hamza Banned Banned

    Apr 12, 2010
    716
    Here is Tutorial :
    First Install UBUNTU MINIMAL .
    Then ..

    VNC on Ubuntu 10.04
    I have a linux Ubuntu 8.10 VPS that I would like to have GUI and use it as remote desktop pc just like what we can do with Windows XP. Here are the steps that I run.
    1. Most of the VPS that delivered by VPS hosting provider is minimal setup of linux, it means that most of the time it only have SSH server installed and the other services such as HTTP server, FTP server, Mail server must be installed by our self. The default setup of VPS linux also doesn’t have window manager (GUI) hence we must install it first:
    sudo apt-get install ubuntu-desktop
    2. Configure the Gnome Desktop Manager and XServer
    sudo /etc/init.d/gdm start
    or
    start gdm
    sudo dpkg-reconfigure xserver-xorg
    3. After we installed a window manager, next step is to install the remote desktop server, for linux we use TightVNC
    sudo apt-get install tightvncserver
    4. Next we need to configure the remote desktop server and create a password to access the VPS via its GUI. This command will start the server, you will be asked for a password, this password will be used as authentication when you connect to the VPS, make sure you have a strong password.
    vncserver :1 -geometry 1024x768 -depth 16 -pixelformat rgb565
    5. Now, if you execute command
    ps aux
    You should see an Xtightvnc process:
    Xtightvnc :1 -desktop X –auth
    This means the setting is OK and VNC server is running fine.

    6. The default VNC server doesn’t use Gnome window manager as default, to run Gnome as default we must do some changes on the configuration file.
    sudo nano ~/.vnc/xstartup
    Comment "x-window-manager" and add this on the end of file:
    gnome-session &
    export XKL_XMODMAP_DISABLE=1
    so it will look like this:
    ---------------------------------------------------------------------------------
    #!/bin/sh

    xrdb $HOME/.Xresources
    xsetroot -solid grey
    x-terminal-emulator -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
    #x-window-manager &
    gnome-session &
    export XKL_XMODMAP_DISABLE=1
    -----------------------------------------------------------------------------------
    7. Next, do a reboot. Usually a reboot is not needed, but just to make sure you can do it.
    sudo reboot
    8. Start the VNC server:
    vncserver :1 -geometry 1024x768 -depth 16 -pixelformat rgb565
    9. Download Tight VNC client here: http://www.tightvnc.com/download.html
    10. After you install it, run the VNC client and insert your VPS IP address and VNC server number on the VNC Server field and click on “Connect”. In this tutorial the VNC server number is :1, so you must fill in :1

    You will be asked for a password to access the remote desktop, this password is the one you set on step 4.

    Xampp In Ubuntu :
    wget http://sourceforge.net/projects/xampp/files/XAMPP%20Linux/1.7.2/xampp-linux-1.7.2.tar.gz/download
    sudo tar -xvzf xampp-linux-1.7.2.tar.gz -C /opt
    sudo /opt/lampp/lampp start
     
  6. SHiTHEAD

    SHiTHEAD New Member Member

    Jul 12, 2010
    13
    lol just reading this tutorial on other blog :D thanks mate...
     
  7. SHiTHEAD

    SHiTHEAD New Member Member

    Jul 12, 2010
    13
    Can anyone tell me how to fix this error :
    Code:
    sudo apt-get command not found
     

Share This Page